"Cybersecurity & Infrastructure Security Agency" Posts

Hackers Target VMware vCenter Server Vulnerability: What MSSPs Need to Know

Hackers target & exploit VMware vCenter Server Vulnerability known as CVE-2021-22005. MSPs & MSSPs should follow this VMware patching information for customers.

President Biden Signs Cybersecurity for Critical Infrastructure Memorandum

President Biden memorandum demands U.S. critical infrastructure companies strengthen their cybersecurity. Potential MSSP & MDR service provider implications explained.